Plug One.1 Adept

    Requirements:
    You must have the Weekly Strike DLC
    You must be of 1595+ Power Level
     

Categories: ,